const regex = new RegExp('(A|D)?R?(B|C|E|F)?(G[12]?)?L?S?(M[12]?)?', '')
const str = `ARFLSM2Z`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}