const regex = /^(?!.*?\d{3})[a-zA-Z0-9\+\$\\\/#]{6,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*?\\d{3})[a-zA-Z0-9\\+\\$\\\\\\\/#]{6,}$', 'gm')
const str = `pass12p
pass125p
goo12gf3fg4
pass125676676p`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);