$re = '/^(?!.*?\d{3})[a-zA-Z0-9\+\$\\\\\/#]{6,}$/m';
$str = 'pass12p
pass125p
goo12gf3fg4
pass125676676p';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;