re = /^(?!.*?\d{3})[a-zA-Z0-9\+\$\\\/#]{6,}$/m
str = 'pass12p
pass125p
goo12gf3fg4
pass125676676p'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result