package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\-*\d+(?:.\d+)?$`)
var str = `123456.78912445
-12345.7777777899
1234567
-12345678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}