$re = '/^\-*\d+(?:.\d+)?$/m';
$str = '123456.78912445
-12345.7777777899
1234567
-12345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);