re = /^\-*\d+(?:.\d+)?$/m
str = '123456.78912445
-12345.7777777899
1234567
-12345678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end