const regex = /(.*,)|([^"~]+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*,)|([^"~]+)', 'gmi')
const str = `"1234567123456","T","TEST1~TEST2~TEST3~TEST4~TEST5"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}