$re = '/(.*,)|([^"~]+)/mi';
$str = '"1234567123456","T","TEST1~TEST2~TEST3~TEST4~TEST5"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);