// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)(.*,)|([^"~]+)"#).unwrap();
let string = "\"1234567123456\",\"T\",\"TEST1~TEST2~TEST3~TEST4~TEST5\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}