using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!0+)(?:\d+(?:[.,]\d{0,2})?)?$";
string input = @"It should accept:
1
11,00
100,88
100
11.00
100.88
Shouldn't accept:
0
-5
0,55
0.55
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}