import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!0+)(?:\\d+(?:[.,]\\d{0,2})?)?$";
final String string = "It should accept:\n"
+ "1\n"
+ "11,00\n"
+ "100,88\n"
+ "100\n"
+ "11.00\n"
+ "100.88\n\n"
+ "Shouldn't accept:\n"
+ "0\n"
+ "-5\n"
+ "0,55\n"
+ "0.55\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}