$re = '/^(?!0+)(?:\d+(?:[.,]\d{0,2})?)?$/m';
$str = 'It should accept:
1
11,00
100,88
100
11.00
100.88
Shouldn\'t accept:
0
-5
0,55
0.55
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);