re = /^(\w{4,}?)(?:es|s|e|x)$/m
str = 'I am trying to delete all word suffixes -es, -s, -e or -x of all words that have at least 4 characters after removing the suffix, using regex in Python.
There are some examples of desired output (in French):
technologiques
→ technologiqu
pares
→ pare (the word is too small so it does not remove the "es", only the "s")
bas
→ bas (the word is too small so it does not do anything)
matériaux
→ materiau
sièges
→ sieg
siege
→ sieg
feuilletées
→ feuilleté
dos
→ dos
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result