import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"^(\w{4,}?)(?:es|s|e|x)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
I am trying to delete all word suffixes -es, -s, -e or -x of all words that have at least 4 characters after removing the suffix, using regex in Python.
There are some examples of desired output (in French):
technologiques
→ technologiqu
pares
→ pare (the word is too small so it does not remove the "es", only the "s")
bas
→ bas (the word is too small so it does not do anything)
matériaux
→ materiau
sièges
→ sieg
siege
→ sieg
feuilletées
→ feuilleté
dos
→ dos
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)