$re = '/<.*?>(*SKIP)(*FAIL)|1/';
$str = '<h0><h1><h2><h3>
<table border="1">
1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);