// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<.*?>(*SKIP)(*FAIL)|1").unwrap();
let string = "<h0><h1><h2><h3>
<table border=\"1\">
1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}