$re = '/[^A-Z]+|(?:(?=[A-Za-z]*[a-z])\b[A-Za-z]+\b)|(?:\b[A-Z]+\b(?=[^a-z]+[A-Z])(?:[^a-z]*\b[A-Z]+\b)*\b)/';
$str = 'This is a sentence WITH some capitalised WORDS
IN it AS well as
MULTILINING
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);