const regex = /s(\d{1,2})e(\d{1,2})/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('s(\\d{1,2})e(\\d{1,2})', 'gi')
const str = `S3E1 hehehe bla s09e12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}