using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(href=""([^""]+).*(?=img src))|(img src=""([^""]*))";
string input = @"<a href=""I NEED THIS1""> <img src=""I NEED THIS2""> </a>
<a href=""I DONT NEED THIS"" title=""something""> </a>
<a href=""I NEED THIS3"" title=""blah""> <figure> <img src=""I NEED THIS4"" alt=""> </figure> </a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}