import Foundation
let pattern = #"(href="([^"]+).*(?=img src))|(img src="([^"]*))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<a href="I NEED THIS1"> <img src="I NEED THIS2"> </a>
<a href="I DONT NEED THIS" title="something"> </a>
<a href="I NEED THIS3" title="blah"> <figure> <img src="I NEED THIS4" alt=""> </figure> </a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)