import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!#)(?:(?<=_FILE).+\"(.+)\")";
final String string = "# ---------------------------------------------------------------------------- #\n"
+ "# Packages\n"
+ "# ---------------------------------------------------------------------------- #\n\n"
+ "set_global_assignment -name VHDL_FILE [file join $::quartus(qip_path) \"file_1_test_1_qip.vhd\"]\n"
+ "set_global_assignment -name VHDL_FILE [file join $::quartus(qip_path) \"file_2_test_1_qip.vhd\"]\n"
+ "set_global_assignment -name VHDL_FILE [file join $::quartus(qip_path) \"file_3_test_1_qip.vhd\"]\n\n"
+ "# Register Tool set_global_assignment -name VHDL_FILE [file join $::quartus(qip_path) \"file_INVALID_test_1_qip.vhd\"]\n\n"
+ "# ---------------------------------------------------------------------------- #\n"
+ "# Sub Modules\n"
+ "# ---------------------------------------------------------------------------- #\n\n"
+ "set_global_assignment -name QIP_FILE [file join $::quartus(qip_path) \"module_test_2.qip\"]\n"
+ "set_global_assignment -name QIP_FILE [file join $::quartus(qip_path) \"module_test_3.qip\"]\n\n"
+ "# ---------------------------------------------------------------------------- #\n"
+ "# Module Files\n"
+ "# ---------------------------------------------------------------------------- #\n\n"
+ "set_global_assignment -name VHDL_FILE [file join $::quartus(qip_path) \"file_4_test_1_qip.vhd\"]\n"
+ "set_global_assignment -name VHDL_FILE [file join $::quartus(qip_path) \"file_5_test_1_qip.vhd\"]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}