# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!#)(?:(?<=_FILE).+\"(.+)\")"
test_str = ("# ---------------------------------------------------------------------------- #\n"
"# Packages\n"
"# ---------------------------------------------------------------------------- #\n\n"
"set_global_assignment -name VHDL_FILE [file join $::quartus(qip_path) \"file_1_test_1_qip.vhd\"]\n"
"set_global_assignment -name VHDL_FILE [file join $::quartus(qip_path) \"file_2_test_1_qip.vhd\"]\n"
"set_global_assignment -name VHDL_FILE [file join $::quartus(qip_path) \"file_3_test_1_qip.vhd\"]\n\n"
"# Register Tool set_global_assignment -name VHDL_FILE [file join $::quartus(qip_path) \"file_INVALID_test_1_qip.vhd\"]\n\n"
"# ---------------------------------------------------------------------------- #\n"
"# Sub Modules\n"
"# ---------------------------------------------------------------------------- #\n\n"
"set_global_assignment -name QIP_FILE [file join $::quartus(qip_path) \"module_test_2.qip\"]\n"
"set_global_assignment -name QIP_FILE [file join $::quartus(qip_path) \"module_test_3.qip\"]\n\n"
"# ---------------------------------------------------------------------------- #\n"
"# Module Files\n"
"# ---------------------------------------------------------------------------- #\n\n"
"set_global_assignment -name VHDL_FILE [file join $::quartus(qip_path) \"file_4_test_1_qip.vhd\"]\n"
"set_global_assignment -name VHDL_FILE [file join $::quartus(qip_path) \"file_5_test_1_qip.vhd\"]")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.