#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(abc|bcd|cde|def|efg|fgh|ghi|hij|ijk|jkl|klm|lmn|mno|nop|opq|pqr|qrs|rst|stu|tuv|uvw|vwx|wxy|xyz)(19\d{2}|20[01]\d)(10{1,3}|[25]0{1,2})\d"
Local $sString = "abc1500100" & @CRLF & _
"mno16001001" & @CRLF & _
"xyz180010000" & @CRLF & _
"opq2001101" & @CRLF & _
"opq1901101" & @CRLF & _
"opq2019101" & @CRLF & _
"opq20192001" & @CRLF & _
"opq20105001" & @CRLF & _
"opq197010000" & @CRLF & _
"opq2020101" & @CRLF & _
"" & @CRLF & _
"abd1888101" & @CRLF & _
"abc1499101" & @CRLF & _
"abc2021101" & @CRLF & _
"abc2020201"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")