import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(abc|bcd|cde|def|efg|fgh|ghi|hij|ijk|jkl|klm|lmn|mno|nop|opq|pqr|qrs|rst|stu|tuv|uvw|vwx|wxy|xyz)(19\\d{2}|20[01]\\d)(10{1,3}|[25]0{1,2})\\d";
final String string = "abc1500100\n"
+ "mno16001001\n"
+ "xyz180010000\n"
+ "opq2001101\n"
+ "opq1901101\n"
+ "opq2019101\n"
+ "opq20192001\n"
+ "opq20105001\n"
+ "opq197010000\n"
+ "opq2020101\n\n"
+ "abd1888101\n"
+ "abc1499101\n"
+ "abc2021101\n"
+ "abc2020201";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}