package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(abc|bcd|cde|def|efg|fgh|ghi|hij|ijk|jkl|klm|lmn|mno|nop|opq|pqr|qrs|rst|stu|tuv|uvw|vwx|wxy|xyz)(19\d{2}|20[01]\d)(10{1,3}|[25]0{1,2})\d`)
var str = `abc1500100
mno16001001
xyz180010000
opq2001101
opq1901101
opq2019101
opq20192001
opq20105001
opq197010000
opq2020101
abd1888101
abc1499101
abc2021101
abc2020201`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}