# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?\b([A-Z]{3})\b.*/\1/gm;t' <<< "147 EUR | 39927: 86.9 EUR | 39928: 49.35 EUR"