package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?\b([A-Z]{3})\b.*`)
var str = `147 EUR | 39927: 86.9 EUR | 39928: 49.35 EUR`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}