use strict;
my $str = '147 EUR | 39927: 86.9 EUR | 39928: 49.35 EUR';
my $regex = qr/.*?\b([A-Z]{3})\b.*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";