import Foundation
let pattern = #"(^.{3})?."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"hello there"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)