package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(?:(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:\-(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))|(\*))`)
var str = `aaaa
99.1.1.1
1.1.1.999
192.168.2.1
192.168.2.*
192.168.2.10-20
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}