re = /(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(?:(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:\-(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))|(\*))/
str = 'aaaa
99.1.1.1
1.1.1.999
192.168.2.1
192.168.2.*
192.168.2.10-20
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end