import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(?:(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:\\-(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))|(\\*))";
final String string = "aaaa\n"
+ "99.1.1.1\n"
+ "1.1.1.999\n"
+ "192.168.2.1\n"
+ "192.168.2.*\n"
+ "192.168.2.10-20\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}