re = /\/\*([\s\S]*?)\*\//
str = '{
This is line 1
/*This is line 2
This is line 3
This is line 4*/
This is line 5
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end