#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)Only catch above this.*$|tag(.*?)/tag"
Local $sString = "tagcatch 1/tag" & @CRLF & _
"tagcatch 2/tag" & @CRLF & _
"tagcatch 3/tag" & @CRLF & _
"Only catch above this" & @CRLF & _
"tagcatch 4/tag" & @CRLF & _
"tagcatch 5/tag" & @CRLF & _
"Only catch above this" & @CRLF & _
"tagcatch 6/tag"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")