$re = '~Only catch above this.*$|tag(.*?)/tag~s';
$str = 'tagcatch 1/tag
tagcatch 2/tag
tagcatch 3/tag
Only catch above this
tagcatch 4/tag
tagcatch 5/tag
Only catch above this
tagcatch 6/tag';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);