using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Only catch above this.*$|tag(.*?)/tag";
string input = @"tagcatch 1/tag
tagcatch 2/tag
tagcatch 3/tag
Only catch above this
tagcatch 4/tag
tagcatch 5/tag
Only catch above this
tagcatch 6/tag";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}