$re = '/((?:[a-zA-Z]{3} ){2}\d{2} \d{4} \d{2}:\d{2}:\d{2} GMT[+-]\d{4}) \(([^\)\n]+)\)/m';
$str = 'Tue Sep 24 2019 14:12:51 GMT+0000 (Greenwich Mean Time)
Tue Sep 24 2019 14:12:51 GMT+0100 (British Summer Time)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);