// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:[a-zA-Z]{3} ){2}\d{2} \d{4} \d{2}:\d{2}:\d{2} GMT[+-]\d{4}) \(([^\)\n]+)\)").unwrap();
let string = "Tue Sep 24 2019 14:12:51 GMT+0000 (Greenwich Mean Time)
Tue Sep 24 2019 14:12:51 GMT+0100 (British Summer Time)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}