re = /((?:[a-zA-Z]{3} ){2}\d{2} \d{4} \d{2}:\d{2}:\d{2} GMT[+-]\d{4}) \(([^\)\n]+)\)/m
str = 'Tue Sep 24 2019 14:12:51 GMT+0000 (Greenwich Mean Time)
Tue Sep 24 2019 14:12:51 GMT+0100 (British Summer Time)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end