const regex = /^\\.", "^_h5ai/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\\.", "^_h5ai', '')
const str = `_h5ai bob norton cache
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}