use strict;
my $str = '\'This is \\\' the test\'s string\'';
my $regex = qr/(?<!^|\\)'(?!$)/imp;
my $subst = '\\\\\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";