import re
regex = re.compile(r"(?<!^|\\)'(?!$)", flags=re.IGNORECASE | re.MULTILINE)
test_str = "'This is \\' the test's string'"
subst = "\\\\'"
result = regex.sub(subst, test_str)
if result:
print(result)