$re = '/(?<!^|\\\\)\'(?!$)/im';
$str = '\'This is \\\' the test\'s string\'';
$subst = "\\'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;