import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]\\w+\\s+[A-Z]\\w+)|([A-Z]\\w+)(?=\\s+and\\s+[A-Z]\\w+\\s+([A-Z]\\w+))";
final String string = "Russ Middleton and Lisa Murro\n"
+ "Ron Iervolino, Trish and Russ Middleton, and Lisa Middleton \n"
+ "Ron Iervolino, Kelly and Tom Murro\n"
+ "Ron Iervolino, Trish and Russ Middleton and Lisa Middleton ";
final String subst = "$1$2 $3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}