import re
regex = re.compile(r"([A-Z]\w+\s+[A-Z]\w+)|([A-Z]\w+)(?=\s+and\s+[A-Z]\w+\s+([A-Z]\w+))", flags=re.MULTILINE)
test_str = ("Russ Middleton and Lisa Murro\n"
"Ron Iervolino, Trish and Russ Middleton, and Lisa Middleton \n"
"Ron Iervolino, Kelly and Tom Murro\n"
"Ron Iervolino, Trish and Russ Middleton and Lisa Middleton ")
subst = "$1$2 $3"
result = regex.sub(subst, test_str)
if result:
print(result)