re = /([A-Z]\w+\s+[A-Z]\w+)|([A-Z]\w+)(?=\s+and\s+[A-Z]\w+\s+([A-Z]\w+))/m
str = 'Russ Middleton and Lisa Murro
Ron Iervolino, Trish and Russ Middleton, and Lisa Middleton
Ron Iervolino, Kelly and Tom Murro
Ron Iervolino, Trish and Russ Middleton and Lisa Middleton '
subst = '$1$2 $3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result