#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(\d+)(?!.*\1)"
Local $sString = ""/manufacturers/244/rz-xvxcv/images/swed"" & @CRLF & _
""/manufacturers/23/rz-gf/images/sltn"" & @CRLF & _
""/manufacturers/34/rz-dffdf/images/five"" & @CRLF & _
""/manufacturers/23/rz-gfgf/images/lead"" & @CRLF & _
""/manufacturers/322/rz-dfg/images/carr"" & @CRLF & _
""/manufacturers/3789/rz-fgdfgfg/images/zing""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")