import re
regex = re.compile(r"(\d+)(?!.*\1)", flags=re.DOTALL)
test_str = ("\"/manufacturers/244/rz-xvxcv/images/swed\"\n"
"\"/manufacturers/23/rz-gf/images/sltn\"\n"
"\"/manufacturers/34/rz-dffdf/images/five\"\n"
"\"/manufacturers/23/rz-gfgf/images/lead\"\n"
"\"/manufacturers/322/rz-dfg/images/carr\"\n"
"\"/manufacturers/3789/rz-fgdfgfg/images/zing\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")