import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)(?!.*\\1)";
final String string = "\"/manufacturers/244/rz-xvxcv/images/swed\"\n"
+ "\"/manufacturers/23/rz-gf/images/sltn\"\n"
+ "\"/manufacturers/34/rz-dffdf/images/five\"\n"
+ "\"/manufacturers/23/rz-gfgf/images/lead\"\n"
+ "\"/manufacturers/322/rz-dfg/images/carr\"\n"
+ "\"/manufacturers/3789/rz-fgdfgfg/images/zing\"";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}